Forum

tao/install 404 error

Hi all,

I am sure this has been dealt with before - I followed to the letter the instructions to install Tao on an Ubuntu 16.04 box here:

https://hub.taocloud.org/articles/installation-and-upgrading/tao-on-debian-ubuntu-with-apache2-mysql

I am on the very last part, where I need to go to http://taoplatform/tao/install (obviously replacing taoplatform with the DNS name previously set up) and I get:

The requested URL /tao/install was not found on this server.

If I go to the root (say http://taoplatform/) I see the standard Apache2 start page.

Any thoughts?

Comments

  • Hi aharrison,

    If you check the server logs (access first, error second) specified in your TAO vhost, do you have any entry when you try to reach tao/install or the root?

    My assumption is that you use the default vhost used instead of the one you created for TAO.

    Regards,
    Cyril

  • Hi Cyril, where do I find the logs?

  • Hi aharrison,

    It depends on your system and installation, but usually in /var/log/apache2/ on Debian/Ubuntu distributions. However, the path to logs generated for TAO are the one you defined in the TAO specific virtual host.

    Regards,
    Cyril

  • edited October 2017

    Access log:

    192.168.21.8 - - [28/Sep/2017:10:57:52 +0100] "GET / HTTP/1.1" 200 3525 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
    192.168.21.8 - - [28/Sep/2017:10:57:52 +0100] "GET /icons/ubuntu-logo.png HTTP/1.1" 200 3623 "http://taotesting2/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
    192.168.21.8 - - [28/Sep/2017:10:57:52 +0100] "GET /favicon.ico HTTP/1.1" 404 502 "http://taotesting2/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
    192.168.21.8 - - [28/Sep/2017:11:02:32 +0100] "GET / HTTP/1.1" 200 3525 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
    192.168.21.8 - - [28/Sep/2017:11:02:59 +0100] "GET /tao/install HTTP/1.1" 404 503 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
    [...]
    192.168.17.85 - - [28/Sep/2017:17:13:26 +0100] "GET / HTTP/1.1" 200 11576 "-" "Mozilla/5.0 (compatible; PRTG Network Monitor; Windows)"
    192.168.21.8 - - [29/Sep/2017:14:10:05 +0100] "GET / HTTP/1.1" 200 3525 "-" "Mozilla/5.0"
    192.168.21.8 - - [29/Sep/2017:14:10:05 +0100] "GET /nice%20ports%2C/Tri%6Eity.txt%2ebak HTTP/1.0" 404 480 "-" "-"
    192.168.21.8 - - [29/Sep/2017:14:10:05 +0100] "GET / HTTP/1.0" 200 11595 "-" "-"

    Error log:

    [Sun Oct 01 06:25:01.947133 2017] [mpm_prefork:notice] [pid 1126] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
    [Sun Oct 01 06:25:01.947164 2017] [core:notice] [pid 1126] AH00094: Command line: '/usr/sbin/apache2'
    [Mon Oct 02 06:25:01.701173 2017] [mpm_prefork:notice] [pid 1126] AH00171: Graceful restart requested, doing restart

  • Hi aharrison,

    Please keep this topic readable and don't paste such logs here, especially with duplicate entries. Thus, I made the access log shorter.

    A call to /tao/install returns a 404 error which means that you don't use the virtual host created for TAO. Also, a call to / should redirect you to /tao/install, but this is not the case, which confirms my assertion.

    Please attach the virtual host created for TAO.

    Regards,
    Cyril

  • edited October 2017
    NameVirtualHost 127.0.0.1:80
    ServerName localhost
    
    <VirtualHost 127.0.0.1:80>
        ServerAdmin webmaster@taoplatform
        ServerName taoplatform
        DocumentRoot /var/www/taoplatform    
    
        <Directory /var/www/taoplatform>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Require all granted
        </Directory>
     </VirtualHost>
    
  • Hi aharrison,

    Your virtual host for TAO doesn't specify any access or error log, so I assume that logs posted previously are triggered from the default vhost.

    Please add the following lines in your config:

    [...]
         </Directory>
         ErrorLog /var/log/apache2/taoplatform-error.log
         CustomLog /var/log/apache2/taoplatform-access.log combined
    </VirtualHost>
    ...then check if logs are written in these files.

    If not the case, check that the vhost for TAO is indeed enabled.

    Regards,
    Cyril

  • Thanks Cyril,

    I have added the extra lines in taoplatform.conf as suggested. I can also see that a shortcut to this file is in /etc/apache2/sites-enabled/, is there any other requirement to make the vhost enabled?

    After restarting the Apache2 service I do still get the same result unfortunately.

    Thanks

    Adam

  • edited October 2017

    Also just checked the logs after trying to access since the change:

    Access:

    192.168.21.8 - - [04/Oct/2017:09:30:46 +0100] "GET /tao/install HTTP/1.1" 404 503 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"

    Error:

    [Wed Oct 04 09:30:42.922962 2017] [mpm_prefork:notice] [pid 1117] AH00169: caught SIGTERM, shutting down
    [Wed Oct 04 09:30:44.041121 2017] [mpm_prefork:notice] [pid 13562] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
    [Wed Oct 04 09:30:44.041185 2017] [core:notice] [pid 13562] AH00094: Command line: '/usr/sbin/apache2'

    The 2 new files added to vhost config (taoplatform-error.log and taoplatform-access.log) are both still empty.

  • Hi Adam,

    No errors at all are shown in the error log. The default vhost is still used instead of the one defined for TAO.
    What happens if you disable the default vhost and try to reach http://taoplatform/ in your web browser?

    Regards,
    Cyril

  • That wouldn't work as there is no DNS entry for taoplatform on our system (I could add it but doesn't solve the problem). This is on an Ubuntu machine with no GUI.
    So that then brings us to the next question - how do I tell it to use the vhost I have defined, instead of the default one? Sorry TAO is very new to me.

  • Hi Cyril,

    For the sake of being thorough I added a DNS A record to point taoplatform to the same IP, and I get the same result.

    Thanks

    Adam

  • edited October 2017

    I am setting up a brand new ubuntu machine and again following the Tao install instructions. This time I decided to keep the name of my Tao installation as taoplatform to rule out any configuration mistakes I may have made. During the 1.2 part of the guide I did see an error here:

    So I went through the installation and got the same result:

    I am now at a loss, the first one I built about half a year ago went through without any issues.

  • OK! So playing around and using my fairly basic knowledge of Linux web servers, I copied /var/www/taoplatform to /var/www/html and then if I browse to http://taoplatform/taoplatform/tao/install/index.html I can now see the requirements check page.
    So, what file do I edit to make sure that http://taoplatform/ automatically goes to /var/www/taoplatform?

  • I have actually copied the contents of /var/www/html/taoplatform to /var/www/html and can now access the installation wizard from the usual location. I think there may be a step missing from the Ubuntu / Debian install guide.

  • HOWEVER! After finishing the installation steps, http://taoplatform/ takes me back to:

  • Hi aharrison,

    You probably did fall back on the default virtual host, but in that case you have to edit the default vhost so that it matches the configuration required for TAO.

    Regards,
    Cyril

  • Ok I will have to Google what to do here then I think, I don't know anything about configuring a vhost or how to get TAO to work with it.

  • This is actually really frustrating. I have been on this nearly 2 weeks when the install should take 15 mins. I really don't know what to do next. In contrast, Moodle was quick and easy to set up following similar instructions, and unlike TAO we came across no issues. The aim is to run both side by side to see which one to go with but as it stands we can't even complete the setup of TAO so cannot even consider it at this point!

  • Hi aharrison,

    "I don't know anything about configuring a vhost"

    Sorry but this is probably the main issue here and you cannot blame TAO for that.

    You should learn to use Apache 2 and configure two different virtual hosts on the same server, then check that you can access them separately. Once again, your issue is only due to the default vhost being used.

    Regards,
    Cyril

  • Not blaming TAO for my lack of knowledge, but on the same note the install should work if following the instructions to the letter.

  • I also notice there was no response to this error:

    Is it a known issue?

  • Come on... the latter is not an issue, it only means that you cannot have two different versions (5 and 7.0) of the same module (php in this case) loaded at the same time.

    You may use PHP 5.6 for TAO 3.1 and eventually TAO 3.2, but PHP 7.0 is highly recommanded for TAO 3.2.

    Because you requested it, I will ask a proof-read of this tutorial.

    Regards,
    Cyril

  • ERROR: Module worker does not exist! - This is what I was referring to, not the php7.0 already enabled...

  • Come on...

    No need for that - I am having genuine issues getting TAO working and am seeking support

  • Hi aharrison,

    a2dismod worker and worker probably refers to mpm_worker.
    Please try the command a2dismod without parameter and checks the list.

    Btw this tutorial is tagged with the comment work in progress.

    I will correct the tutorial depending on your feedback, thanks.

    Regards,
    Cyril

  • edited October 2017

    Thanks Cyril,

    The output I get:

    Your choices are: access_compat alias auth_basic authn_core authn_file authz_core authz_host authz_user autoindex deflate dir env filter mime mpm_prefork negotiation php7.0 rewrite setenvif status

  • Hi aharrison,

    Only mpm_prefork is on that list, so you should be fine. However, this is the default configuration. You may ignore that step.

    Regards,
    Cyril

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×