Forum

Error on Installing Newest Tao

I'm trying installing new version of tao from github, using following packages :

 "require": {
    "oat-sa/generis": "13.10.1",
    "oat-sa/tao-core": "46.8.1",
    "oat-sa/extension-tao-community": "9.1.0",
    "oat-sa/extension-tao-funcacl": "6.0.1",
    "oat-sa/extension-tao-dac-simple": "6.8.3",
    "oat-sa/extension-tao-testtaker": "7.7.3",
    "oat-sa/extension-tao-group": "6.6.2",
    "oat-sa/extension-tao-item": "10.17.0",
    "oat-sa/extension-tao-itemqti": "25.18.1",
    "oat-sa/extension-tao-itemqti-pci": "6.9.1",
    "oat-sa/extension-tao-itemqti-pic": "5.6.5",
    "oat-sa/extension-tao-test": "14.6.0",
    "oat-sa/extension-tao-testqti": "40.3.2", 
    "oat-sa/extension-tao-outcome": "12.3.1", 
    "oat-sa/extension-tao-outcomeui": "9.5.0", 
    "oat-sa/extension-tao-outcomerds": "7.3.2", 
    "oat-sa/extension-tao-outcomekeyvalue": "5.7.1", 
    "oat-sa/extension-tao-outcomelti": "4.0.0", 
    "oat-sa/extension-tao-delivery": "14.19.0", 
    "oat-sa/extension-tao-lti": "11.14.0", 
    "oat-sa/extension-tao-ltideliveryprovider": "11.5.0",
    "oat-sa/extension-tao-revision": "5.0.2", 
    "oat-sa/extension-tao-mediamanager": "11.6.2",
    "oat-sa/extension-pcisample": "2.10.2",
    "oat-sa/extension-tao-backoffice": "5.1.0",
    "oat-sa/extension-tao-proctoring": "19.20.2", 
    "oat-sa/extension-tao-clientdiag": "7.8.1", 
    "oat-sa/extension-tao-eventlog": "2.10.2",
    "oat-sa/extension-tao-task-queue": "5.5.1", 
    "oat-sa/extension-tao-testqti-previewer": "2.24.0"
  },

When installing, i have following errors :

<br />
<b>Fatal error</b>:  Uncaught Error: Call to a member function get() on null in /taoedge/generis/common/persistence/PersistenceManager.php:203
Stack trace:
#0 /taoedge/generis/common/persistence/PersistenceManager.php(145): oat\generis\persistence\PersistenceManager-&gt;getDriverConfigFeeder()
#1 /taoedge/generis/common/persistence/PersistenceManager.php(115): oat\generis\persistence\PersistenceManager-&gt;createPersistence('default')
#2 /taoedge/tao/install/services/class.CheckDatabaseConnectionService.php(141): oat\generis\persistence\PersistenceManager-&gt;getPersistenceById('default')
#3 /taoedge/tao/install/services/class.CheckDatabaseConnectionService.php(58): tao_install_service in <b>/taoedge/generis/common/persistence/PersistenceManager.php</b> on line <b>203</b><br />

I don't see PersistenceManager.php on previous release of tao.

How can i fix this error ?

Thank you.

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×