Forum

TAO Installation Issues (Debian System)

edited May 11 in General

Good morning ladies and gentlemen,

I seem to be having some issues getting TAO up and running. Upfront I had some issues going through the process of configuring all the separate pieces but everything looked to finally work until I attempted to go to http://TAO-Server/tao, I was met with the page I have attached. I have been crawling through all the documentation and nothing I can find really seems to help point me in the right direction on what to try. I've attempted three different browsers (Google, ForeFox, Brave) and I tried using https, and still nothing. Any advice would be super helpful! Thank you in advance!

Comments

  • Not sure if this helps, but the installation instructions have recently changed on https://www.taotesting.com/user-guide/installation-and-upgrade/ubuntu-and-debian/

    "Ensure the correct version of composer is used. By default, the version of composer installed on Ubuntu and Debian is composer 2. Before you can install TAO you will need to downgrade this to version 1, with the following command:

    sudo composer self-update --1"

  • I had the same problem. I stepped back in installation process by removing everything from /var/www/html/tao/.

    I then installed from git hub.

    Followed the instructions as far as:

    sudo composer install
    sudo chown -R www-data tao
    

    Then continued the installation via the browser option, http:///tao

    I had to change some permissions that where flagged by the installation.

    It works now. I suspect they may be some option missing from the cli install option.

  • I'm having troubles at the last step in the browser based wizard, it throws the following message:

    An exception occurred while executing 'CREATE
    DEFINER = CURRENT_USER
    FUNCTION generis_sequence_uri_provider (modelUri VARCHAR(255))
    RETURNS VARCHAR(255)
    NOT DETERMINISTIC
    READS SQL DATA
    SQL SECURITY INVOKER
    BEGIN
    DECLARE uri VARCHAR(255);
    INSERT INTO sequence_uri_provider (uri_sequence) VALUES (null);
    SELECT CONCAT(modelUri, 'i' , UNIX_TIMESTAMP(), FLOOR(RAND() * 10000), LAST_INSERT_ID()) INTO uri;
    DELETE FROM sequence_uri_provider;
    RETURN uri;
    END;':

    SQLSTATE[HY000]: General error: 1419 You do not have the SUPER privilege and binary logging is enabled (you might want to use the less safe log_bin_trust_function_creators variable) in /var/www/html/tao/tao/install/class.Installator.php at line 442

    If this is the same permission problems you experienced, can you please point out what is to be changed to make it work?

  • I think at the start of the installation it does some checks.

    And resulted in indicating that it needed write permissions to /var/www/html/tao/tao/views/locales/

    sudo chmod go+w /var/www/html/tao/tao/views/locales/

  • Thanks – that fixed something :-)
    But now I'm stuck with this message:

    An exception occured in driver: SQLSTATE[HY000] [1045] Access denied for user 'jostein'@'localhost' (using password: YES) in /var/www/html/tao/tao/install/class.Installator.php at line 442

    The user exists on the server – any ideas?

  • Did you use a different user for the data base and the login? I used admin/admin for the login but a different user for the database.

    The above error looks like a data base login problem.

  • Thanks - I'll make sure rights/users are in order :-)

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×