Forum

Test Delivery Failed

Hello,

I tried to administer a test for 117 students in batches of 30 using the latest TAO 3.0 release of the community edition. The site was hosted on a shared Linux server. The only thing that went correct for us was the initial login. After that it was all downhill. There were considerable lag for the questions to the load. The lag became very noticeable when all the 30 students were logged in. We were letting in students log in one by one because we were worried that the site might act up, which it did!

Are there some configuration steps that must be done prior to the delivery to prevent this?

Thanks,

JJ.

Comments

  • Hi,

    Please read this topic. Same recommendations and same comments... I guess that latter will also apply to your issue.

    I would be interested in knowing your server and network configuration.

    Regards,
    Cyril

  • Hi Cyril,

    Thanks for the reply.

    The site was hosted on a shared Linux server purchased online from a company called BigRock (bigrock.in). Their site claims that the servers are Dell Rack Servers with Intel Xeon-E5 Dual Quad-Core Processors w/HyperThreading and 64GB RAM (1333MHz RDIMMs) and connected through Juniper Switches and Routers. The exact specs are not available. We use the same service provider for hosting our other sites.

    In fact, we had tried to test TAO offline using XAMPP on a Windows 7 Enterprise laptop. But it threw up so many errors and so we just tested it by uploading the zip archive onto our shared hosting server. The installation and configuration and test creation went smoothly. We used it to run a sample test for around 117 students divided into two groups of 53 and 64. For the first batch of 53 students, we made the candidates take tests in groups of 20. There were lot of false starts and tests ran with lots of hiccups. Sometimes the screen froze on a question, other times there were significant load times for even the login screen. For the second batch of 64 students, the tests didn't proceed at all. We managed to complete the exams for just 10 students. For the rest, the site simply refused to load.

    In your reply you had mentioned a load testing service. Are there any that you recommend?

    Thanks,

    JJ.

  • edited December 2017

    Hi JJ,

    Before you consider and try some load testing solution, you should figure out exactly why TAO doesn't run correctly on your system. It may happen for various reasons, however having a quick look at server access and error logs, TAO logs and eventually the outcome client-side using your web browser inspector should give you a clue.

    Also, if your locally installed TAO did throw many errors using Windows and XAMPP, you should also investigate on that issue.

    I highly recommend you to give up on the TAO 3.0 version and to try again with the latest TAO 3.2. TAO 3.0 only works with an old PHP version. TAO 3.1 itself doesn't fully work with PHP 7.0.

    Regards,
    Cyril

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×