Forum

Can't author items in TAO 3.2-RC2.

edited July 2018 in Developers

I initially posted this in the support-category, but this might be more relevant for developers.

I've just installed installed TAO 3.2 on Linux Mint 19 Tara, using apache2 as the server and mysql for the database-server.
Everything seemed to have been installed without problems and it seems that i'm able to do everything i'm supposed to(ie. create tests, test-takers, groups ect.).
Every page i load gives me a bunch of XML-parsing errors - but i'm sure that i have the required php-xml module installed and enabled. It seem to be related to the QTI-items not being loaded correctly due to some bad XML(or the wrong xml-module?), but i'm not sure.
I am able to create new items, however when i try to author an Item, the authoring page doesn't load and the last error displayed in the console is some script error in 'ui/documentViewer/providers/pdfViewer/pdfjs/pageView'.

EDIT:
Here's an image of my console when trying to open authoring page:

Any help would be appreciated!

Edit Admin: Please don't create two similar topics with different categories.

Comments

  • edited July 2018

    Hey Admin.
    There was no way for me to delete my first post and for some reason, I cant edit my post anymore. Any idea why?

  • edited July 2018

    Problem solved, I was using php7.2 instead of php7.0.

  • This is good news that you got it solved, thanks for the feedback.

    Regards,
    Cyril

    NB: About the topic and post creation, the forum setting currently doesn't allow the author to edit or remove it after 1 hour, so this explains that.

  • edited December 2018

    Hello, is this could be a security problem soon, as PHP no longer supports 5.6 and 7.0 versions ? In 2019 for 5.6 and 7.0 is already not supported anymore to be precise according to their roadmap

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×