Forum

Error 404 Main login

I just finished installing TAO 3.2.0 RC2_build in a Godaddy shared server with PHP 5.6. I'm being redirected to the /tao/Main/login but it shows a 404 error.
Has anyone have had this problem before? Do I need to reinstall TAO?

Comments

  • On the old forum, someone tried to do the same on a shared GoDaddy hosting. Have a look at this topic, it may help you.

    Because shared hosting has some strong restrictions that you may not override, it is usually not recommended for installing a web application such as TAO but may work.

    Regards,
    Cyril

  • Thank Cyril. I’ll look into it

  • I'm getting the exact same error. I'm using MySQL and PHP 7.0.31 (LAMP) I have installed TAO 3.2.0 RC2_build as well. I installed in http://FQDN/tao I tried reinstalling and set the folder permissions to 777 but that didn't help either. The "/tao/Main" directory doesn't get created during installation if that helps.

    Thanks!

  • Hello,

    The /tao/Main path is only a virtual path and thus won't show up in your root directory. Anyway, this is probably not the root cause of your issue.

    Do you have the Apache2 rewrite module installed and the AllowOverride directive set to All for the served document root?
    As you installed TAO in a subfolder you probably noticed the warning related to that directive at the requirements check page.

    Regards,
    Cyril

  • I too have the same problem. I am able to complete the install (seemingly) until the last screen which then redirects me to http://localhost/tao/Main/login & 404. There is certainly no path on disk that matches "./tao/Main".

    When requesting "localhost/" (with browser cache disabled), my terminal/log window shows...

    php | 192.168.128.4 - 18/Sep/2018:21:38:26 +0000 "GET /index.php" 302
    apache | 192.168.128.1 - - [18/Sep/2018:21:38:26 +0000] "GET / HTTP/1.1" 302 -
    apache | 192.168.128.1 - - [18/Sep/2018:21:38:26 +0000] "GET /tao/Main/login HTTP/1.1" 404 212

    (php = web service to php-fpm, apache = apache web server, which proxies php requests to php service)

    I enabled error_log in php.ini (set to /var/log/php_errors.log), but am not seeing any error message or stacktrace to try and pinpoint the problem.

    FWIW: v3.2 RC2, and docker (based off this repo initially, with tao git cloned and branch selected of v3.2 RC2 into "public_html", choco install composer, composer install, then docker-compose up --build in parent directory, ./tao/install/log/install.log here

  • Fixed problem by deleting/creating/composing tao source, then adding the following to my apache conf file that docker includes, LoadModule rewrite_module /usr/local/apache2/modules/mod_rewrite.so (the module was present, it was just disabled in the main conf). System seems to be fully working now.

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×