Error 505 when creating a new delivery

Hello all,

I have been getting this error while trying to publish a test into a delivery "Error 505", after looking into the apache2 error log, I found the below error:

"PHP Fatal error: Cannot use 'Object' as class name as it is reserved in /srv/www/htdocs/tao/vendor/qtism/qtism/qtism/data/content/xhtml/Object.php on line 42, referer:"

I am on a fresh TAO 3.2.0-RC2 installation and this is the first time i am trying to create a delivery, i have php 7.3.3 and Apache/2.4.38 (Linux/SUSE).

I have done the patch where I change Object to QtiObject, even tried changing the class name mentioned in the error to QtiObject, however as expected this threw different errors.
Looking forward to your support

Kind Regards,
Mudar Kadah


  • Hi this has been patched and the fix is available in the 3.3 RC01 which can be found here:



  • hello amy,

    Thanks for your quick response, however pardon my ignorance, can you nudge me into how i can incorporate this patch into my build, tried the Readme.txt file within however without much luck

    thanks !!

  • There isn't an upgrade path yet from 3.2 to the release candidate for 3.3. You would need to do a fresh install.



  • edited April 16

    Thanks, i wasn't sure at first how to do the installation from the referred package, in the new installation process, the checking configuration requirements keep loading with no response, I am getting the below error in the console:
    XML Parsing Error: syntax error
    Line Number 1, Column 1:

    Looking at the XML response, I am getting the below error, instead of the xml which why I am getting the above. in the xml response i am getting an error saying that it's missing a manifest file. see the full error below:
    Fatal error: Extension Manifest file could not be found in '/srv/www/htdocs/tao/tao/install/utils/../../../taoQtiTestPreviewer/manifest.php'.

    any idea how I can fix it ?

    Still with the i have php 7.3.3 and Apache/2.4.38 (Linux/SUSE). Trying to install the package your refereed to.

    Many thanks,

    2.JPG 101.6K
  • You can find instructions on how to add an extension here -

    As far as the error I've reached out to development but we are in the process of working on the new release.



  • edited April 16

    Hello Amy,
    Thanks a lot, managed to fix it. it turns out this happens if i did a composer update after the install. again thanks a lot for your quick response.

    However still i am getting a new issue when finalizing the installation, when i click on install as per picture 3, the process runs for a bit then i get the install button green again (in an endless loop), in the console i get the below error:

    TypeError: data is undefined[Learn More] step_finalization.js:116:25
    jQuery 4

    See attached photo 5, however if i refresh the page it appears that the installtion goes to production mode and i can access the login page, however the login button is grayed out. see photo 4.

    Thanks !!!

    3.JPG 92.6K
    5.JPG 176.2K
  • amyamy
    edited April 16

    What version is this on? And openSUSE still(Leap or Tunbleweed)?

  • Hello Amy,
    This is 3.3.0-sprint69 from i got the package from the link your shared then installed with composer.
    I am using SUSE Linux Enterprise Server 12 (x86_64)
    VERSION = 12

    the above is fixed by following the below: changing Object to QtiObject:
    doing the changes below:

    Do the same for this:
    Object -> QtiObject: /srv/www/htdocs/vendor/qtism/qtism/qtism/data/storage/xml/marshalling/ ContentMarshaller.php
    if the below step is not done, it leads back to same original error:
    Object -> QtiObject line41: /srv/www/htdocs/tao/vendor/qtism/qtism/qtism/data/content/xhtml
    after the above change:
    creating the delivery still creates an error, which is:
    QTI Test "QTI Example Test" publishing failed.
    The QTI Test XML or one of its dependencies is malformed or empty.

    Many thanks,
    Mudar Kadah

    6.JPG 146.8K
  • I saw a post where another member had a similar issue, however the solution wasn't very clear, do you have a clue what he is talking about ?
    see the post here:

  • Reading the reply it sounds like a permissions issue to where the webserver was writing. so the person moved the temp folder to a location within the webserver. Another option might just be to change ownership of the folder to be writable by the apache user.



  • Hello Amy,

    Again really thanks you for your continuous support, any idea where that temp folder is, as I wasn't able to figure that out.


  • Mudar,

    I'm not that up on SUSE I'm afraid but from the screenshot in the other post his errors were in /tmp. Also, check the permissions for the data/ directory within your installation. If you haven't set your system to debug yet that might help narrow down the issue as well.



Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy