Devtools not installed

Help, why not installed?

c:\Users\Arman\Downloads\OSPanel\domains\>composer require "oat-sa/extension-tao-devtools"
Using version dev-master for oat-sa/extension-tao-devtools
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Can only install one of: ccampbell/chromephp[4.1.0, dev-master].
- Can only install one of: ccampbell/chromephp[dev-master, 4.1.0].
- Can only install one of: ccampbell/chromephp[4.1.0, dev-master].
- oat-sa/extension-tao-devtools dev-master requires ccampbell/chromephp ~4.1.0 -> satisfiable by ccampbell/chromephp[4.1.0].
- Installation request for oat-sa/extension-tao-devtools dev-master -> satisfiable by oat-sa/extension-tao-devtools[dev-master].
- Installation request for ccampbell/chromephp (locked at dev-master) -> satisfiable by ccampbell/chromephp[dev-master].

Installation failed, reverting ./composer.json to its original content.


  • The extension was not installed properly or there may be a conflict and the dependency is used by multiple packages. You should try deleting the composer.lock file, or run composer update first and then try the composer require again. Or if it doesn't work, then share the composer.json file with us.



  • Can you confirm what version of TAO yo are using?



  • Tell me how to fix this problem, please?

  • One of the team did a fresh install with the given composer.json file and it worked well without any problem. He suggested doing the following:
    1) delete the vendor folder and the taoDevTools folder
    2) delete the composer.lock file
    3) run composer install

    If it is still doesn't work, run composer why ccampbell/chromephp -t and send us the result.



  • Thanks, I will try

  • Hi,

    I'm also having problems with this. When i re-run everything with composer install, the login page disappears.

    The devTools extension refuses to appear.



  • I installed the most recent version 3.3.0-RC02

    I get this error though:

    When running the installExtension.php script

    Uncaught common_ext_OutdatedVersionException 'Installed version of generis 8.2.2 does not satisfy required >=11.1.0 for taoDevTools' in

  • Well I got it to work - by matching the correct version I guess.

    composer require "oat-sa/extension-tao-devtools":"4.2.3" worked
    the dev branch doesn't really work.

  • List of packages here (if ever anyone needs this link):

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy