Forum

Issue with taoQtiTestPreviewer

edited June 2 in Support

Dear Team,
Your kind help is appreciated to solve the below issue

I tried to upgrade the "oat-sa/tao-core" from "~25.1.0" "~28.2.0" but when I run the command "sudo -u apache php tao/scripts/taoUpdate.php" I got the below error.

[root@taotest01-local taoplat]# sudo -u apache php tao/scripts/taoUpdate.php
PHP Fatal error: Uncaught common_exception_Error 'Missing extensions taoQtiTestPreviewer for: taoCe' in /var/www/taoplat/generis/helpers/class.ExtensionHelper.php(74) #0 /var/www/taoplat/tao/models/classes/class.LanguageService.php(278): helpers_ExtensionHelper::sortByDependencies(Array)

1 /var/www/taoplat/tao/models/classes/class.LanguageService.php(249): tao_models_classes_LanguageService->buildServerBundle('da-DK')

2 /var/www/taoplat/tao/models/classes/class.LanguageService.php(174): tao_models_classes_LanguageService->generateServerBundles()

3 /var/www/taoplat/tao/models/classes/extension/UpdateExtensions.php(52): tao_models_classes_LanguageService->generateAll()

4 /var/www/taoplat/tao/scripts/taoUpdate.php(28): oat\tao\model\extension\UpdateExtensions->__invoke(Array)

5

thrown in /var/www/taoplat/generis/helpers/class.ExtensionHelper.php on line 74
[root@taotest01-local taoplat]# sudo -u apache php tao/scripts/installExtension.php taoQtiTestPreviewer
PHP Fatal error: Uncaught common_ext_OutdatedVersionException 'Installed version of taoTests 6.4.1 does not satisfy required >=8.0.0 for taoQtiTestPreviewer' in /var/www/taoplat/generis/helpers/class.ExtensionHelper.php(164) #0 /var/www/taoplat/generis/common/ext/class.ExtensionInstaller.php(88): helpers_ExtensionHelper::checkRequiredExtensions(Object(common_ext_Extension))

1 /var/www/taoplat/generis/helpers/class.InstallHelper.php(109): common_ext_ExtensionInstaller->install()

2 /var/www/taoplat/generis/helpers/class.InstallHelper.php(81): helpers_InstallHelper::install(Object(common_ext_Extension), Array)

3 /var/www/taoplat/tao/helpers/InstallHelper.php(43): helpers_InstallHelper::installRecursively(Array, Array)

4 /var/www/taoplat/tao/scripts/installExtension.php(36): oat\tao\helpers\InstallHelper::installRecursively(Array)

5

thrown in /var/www/taoplat/generis/helpers/class.ExtensionHelper.php on line 164

[root@taotest01-local taoplat]#

After running the command "sudo -u apache php tao/scripts/installExtension.php taoQtiTestPreviewer"

I got the below error.

[root@taotest01-local taoplat]# sudo -u apache php tao/scripts/installExtension.php taoQtiTestPreviewer
PHP Fatal error: Uncaught common_ext_OutdatedVersionException 'Installed version of taoTests 6.4.1 does not satisfy required >=8.0.0 for taoQtiTestPreviewer' in /var/www/taoplat/generis/helpers/class.ExtensionHelper.php(164) #0 /var/www/taoplat/generis/common/ext/class.ExtensionInstaller.php(88): helpers_ExtensionHelper::checkRequiredExtensions(Object(common_ext_Extension))

1 /var/www/taoplat/generis/helpers/class.InstallHelper.php(109): common_ext_ExtensionInstaller->install()

2 /var/www/taoplat/generis/helpers/class.InstallHelper.php(81): helpers_InstallHelper::install(Object(common_ext_Extension), Array)

3 /var/www/taoplat/tao/helpers/InstallHelper.php(43): helpers_InstallHelper::installRecursively(Array, Array)

4 /var/www/taoplat/tao/scripts/installExtension.php(36): oat\tao\helpers\InstallHelper::installRecursively(Array)

5

thrown in /var/www/taoplat/generis/helpers/class.ExtensionHelper.php on line 164

[root@taotest01-local taoplat]#

Thank you in advance for your support.
Best regards,

Comments

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×