Forum

Packaging PCI .zip

Hey,
I'm looking at making my own PCI's. Very early stages of learning how this is done. One early issue I've run into is uploading a PCI. Using already built PCI's that have been built and zipped off gihub I'm able to upload those no problem. If I take one of those built/zipped PCI's and unzipp it and rezip it (literally make no changes) and then try to upload it I get an error "ZIP package does not have a manifest at root path: imsPciCreator.json" (which is does have a pciCreator.json).

Let me be clear. .zip straight from developers gihub uploads fine. Unzip and rezip same PCI and I get the above error.

Any ideas?

Comments

  • Can you provide a link?

  • https://github.com/EJTH/open-tao-pcis in the folder 'builds' I was just using the 'wordrank' one. If I upload wordrank.zip into TAO it works just fine. If I unzip that folder and re-zip it I get the error.

    So I'm wondering if there is something special in the process of zipping a PCI that I'm missing?

  • I should state its not just the 'wordrank' pci, its any pci. If I unzip and rezip it without making any changes to the files within I get the error.

  • @ejth is this something you can help with?

  • I have tried it on both a MAC and Ubuntu machine. Both have the same issue....

  • I will take a look at it.

  • So its not a problem specific to my repo?

    What zip program are you using?

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×