Forum

Change in hosting URL from http to https

We have included SSL certificate in our hosting site which has caused error 500 on clicking on folder structures in Item Creation , Test Creation , Test Takers ,Groups,Deliveries,Result and media.
Please provide a solution for how to run it smoothly without an error and which files needs to be configured for https url.

Comments

  • Hi, did you change the new URL in config/generis.conf.php (ROOT_URL constant) accordingly?

    Regards,
    Cyril

  • edited October 18

    I ran into this issue too. As Cyril mentions changing the config/generis.conf.php is required.

    I changed both the below to https
    define('LOCAL_NAMESPACE','https://site url');
    define('ROOT_URL','https://site url');

    Also you will need to configure your certificate somewhere. I have a separate virtual hosts file that I updated:

    sudo nano /etc/httpd/conf.d/tao.conf

    Note that in addition the the certificate location info you need to make sure the ServerName matches what you used when you created the certificate request.

    EDIT: Markdown does not appear to be working so I removed the tags affecting formatting.

        VirtualHost 127.0.0.1:80                                                        
        ServerAdmin admin@hostname                                                    
        ServerName tao                                                                
        DocumentRoot /var/www/html/tao                                                
    
        Directory /var/www/html/tao                                                
            Options Indexes FollowSymLinks MultiViews                                 
            AllowOverride All                                                         
            Require all granted                                                       
        /Directory                                                                 
        /VirtualHost                                                                   
    
        VirtualHost *:443                                                               
        ServerAdmin admin@hostname                                                    
        ServerName MUST_MATCH_CERTIFICATE                                             
        DocumentRoot /var/www/html/tao                                                
        ErrorLog /var/www/html/tao_errorlog.log                                       
        SSLEngine on                                                                  
        SSLProtocol all                                                               
        SSLCertificateFile /<filelocation>/ssl_certificate.crt                        
        SSLCertificateKeyFile /<filelocation>/site.key                 
        SSLCertificateChainFile /<filelocation>/ssl_intermediate_certificate.crt      
    
        Directory /var/www/html/tao                                                 
            Options Indexes FollowSymLinks MultiViews                                 
            AllowOverride All                                                         
            Require all granted                                                       
        /Directory                                                                  
        /VirtualHost
    
Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×