Forum

URL http://mytaoserver/tao doesn't work

Hi everyone,
I'm new on this site and I'm not a specialist in php ...
I've been working to install TAO since a few days but I still have the same error at the end of the procedure page, more precisly at the moment to connect to http://mytaoserver/tao
Here the page I obtain :smile:

Forbidden
You don't have permission to access /tao/ on this server.
Apache/2.4.38 (Debian) Server at tao-snao Port 80

What do I do wrong ?
Thanks for your help

Comments

  • I'm particularly not sure about the modifications in the apache2.conf, can someone help me to complete this step of the procedure ?

  • Are you using the latest version of TAO and following the Ubuntu instructions in the admin guide? https://adminguide.taotesting.com/3.3/installation-and-upgrade/ubuntu-and-debian

  • Hi Amy,

    Yes, I followed the more precisly as I could the instructions for the version 3.3 (but some things went wrong during the apache configuration so I had to adapt a little - see below).

    I have doubts about the Apache2.conf file because it is not very clear (for me) in the instructions : I don't know where to insert the line "ServerName = mytaoserver" so I inserted it at the extrem end of the file. In the same file, I also replaced the lines :


    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted


    by


    Options FollowSymLinks MultiViews
    AllowOverride all
    Allow from all


    but I'm not sure I replaced the good lines ...

    I had a few others problems during the Apache configuration, so I had to improvise :
    - I wasn't able to install "php-mysql" so I installed "default-php-mysql"
    - "sudo pecl install mcrypt-1.0.1" didn't work so I used "sudo pecl install mcrypt-1.0.2"
    - php seems to be in version 7.3, so I change the command into "sudo nano /etc/php/7.3/cli/php.ini"

    I installed everything on a Debian 10 Buster and modified the sources.list file with these depos :

    deb http://deb.debian.org/debian buster main
    deb-src http://deb.debian.org/debian buster main

    deb http://deb.debian.org/debian-security/ buster/updates main
    deb-src http://deb.debian.org/debian-security/ buster/updates main

    deb http://deb.debian.org/debian buster-updates main
    deb-src http://deb.debian.org/debian buster-updates main

    I hope I didn't forget anything,

    Thanks for your answer
  • Yeah you'd need to adjust a little for the differences between Ubuntu and Debian, but they're very similar as Ubuntu is based on Debian.

    I tucked my ServerName higher into the file near the commented out ServerRoot:

    ServerRoot "/etc/apache2"

    ServerName 192.168.1.114

    For configuration of the directory itself you'll want to tuck it with the other directory entrries:

    Options FollowSymLinks MultiViews
    AllowOverride all
    Allow from all

    Keep an eye on the logs, and if you need to do small changes and double check functionality before adding more to help narrow down where your issues are.

  • Hi Amy,
    Thanks again for your help :o)

    It's a bit better now, but I still can't launch the TAO web installer because the page mytaoserver/tao says :

    "
    Your browser does not meet the technical requirements to run TAO.
    TAO Logo
    Connect to the TAO platform
    Guest access
    © 2013 - 2019 · 3.3.0-RC02 · Open Assessment Technologies S.A. · All rights reserved.
    "

    Can you help me once again ?
    I don't know where to find the logs you're talking about ...

  • I'd start with the apache logs which are off of /var/log/ for configuring system debugging checkout https://adminguide.taotesting.com/3.3/troubleshooting/set-system-to-debug-mode

  • Now, when I enter the URL (http://mytaoserver/tao) in Firefox, here's what I get :
    "
    http:// mytaoserver/tao/Main/login?redirect=%2Ftao%2F&msg=Access%20denied.%20Please%20renew%20your%20authentication%21
    "
    Yes, you see well : he adds a space before the name of the server ...
    I've checked all the files, I have no idea why I get such a behaviour

  • amyamy
    edited September 4

    Look in your apache conf and in your hosts files. Also check in config/generis.conf.php file

  • Hi Amy,
    Your help is very precious :)
    I've been able to remove the space in the URL. It was a line in the generis.con.php file.
    I don't know what/where to search in my apache conf, can you help me one more time ?

  • Look at the ServerName you set and just make sure there's nothing there. You may need to check your .htaccess files as well

  • Look at the ServerName you set and just make sure there's nothing there. You may need to check your .htaccess files as well

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×