Forum

Installation

I have tried to install this manually and automatically and failed at both. I really don't understand why this is so difficult. Why isn't there a VM of this already setup I can use in VMWare? Why isn't there a VM on AWS marketplace? (seriously there are like 10 versions of Linux LAMP servers on there but NOTHING for Tao Testing) Basically, why have I got to go through all these hoops just to get something touted as "automatic install" working on my Windows box? I had this program working years ago on Windows XP I think but could never get it working when I tried before in Windows 10, and I circled back around to it again today and hours later still the same thing, doesn't work. Problem after a problem I have to look up and fix and still it doesn't work. The installation guide is a joke.

Comments

  • The Windows setup is an auto-installer if you are having issues on Windows10 please let us know. For CentOS, Ubuntu, and MacOS we do have easy to follow instructions located here https://adminguide.taotesting.com/3.3/installation-and-upgrade/prerequisites. As with many Open Source projects we wanted too make it as unobtrusive as possible but have repeatable documentation to meet multiple use cases as far as environments.

  • I always love it when someone says "easy to follow instructions". I have never found anyone who felt like instructions they wrote and understands are anything but easy. I don't know Linux, and I can guarantee you if I tried to follow those instructions they wouldn't work. I'd need to be in some mode, or I'd need to assign some permissions or be in some folder or something that Linux people would be "everybody knows that" but I'm not a Linux guy so I DON'T know that, and that makes the instructions incomplete and not easy to follow.

    The Windows installation is just supposed to work with a click... the problem I quit on was it couldn't connect to MariaDB.

  • The Community Edition does expect some level of technical ability as it is a Do-it-yourself edition with Community level support. If you need something more supported then there are the Premium and Enterprise editions.

    The instructions do however include changing permissions and the exact commands to type but would require you to have the Operating System installed.

    As fas as the Windows installation, when following these instructions https://adminguide.taotesting.com/3.3/installation-and-upgrade/windows at what point do you receive an error and what is the exact error? Does your user have sufficient privileges?

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×