Forum

preview and test broken if test input contains certain characters. 3.3-RC02

For example if you create a multiple choice option and have one of the answers like this

{{ var }}

the option will not show up.

Comments

  • Can you provide the exact question and steps to reproduce?

  • Will do.

    1. Create New Item
    2. go to Authoring
    3. Add any common interaction that has a free text field. For example multiple choice
    4. Add any text within {{ }} characters. For example

    1. Go to preview and you will see that it has been stripped.

    It is missing in the actual test as well ( not just the preview ).

  • Hi Markus, I don't know the exact reason why this fails, but my guess would be that the items run through handlebars, where the braces have a special meaning.

    I wonder, what you are trying to achieve. If I had a bit more context, I could maybe come up with a better idea.

  • Hi Dieter,

    I am trying to write some questions around Jinja2 templating. You reference variables through {{ var_name }} syntax.

    https://jinja.palletsprojects.com/en/2.10.x/

  • Since your code pattern is not supported, I have been looking for workarounds, and I think I found one. You could maybe use Unicode U+2774 and U+2775 instead. I tried that quickly and at least in the preview, it worked just fine.

    Regular brackets { } vs. said unicode ones ❴ ❵

    I hope, this helps!

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×