Forum

Issue with videos files

edited November 2 in Developers

Hi All,

I am able to add videos (MP4) link in items as Multimedial interaction and can see it playing in preview.

But when the test takers are getting that item, then media files doesn't play. It just keep on showing progress bar. Please refer the images for reference.


Thanks

Comments

  • Are there any errors in the web server?

  • edited November 5

    Please find the errors below.

    Was trying to upload a video, which can be used by media item:

    Browser logs:
    Media resource http://10.10.11.3:8080/assessment/taoItems/ItemContent/downl…Caudio%2Faac%2Caudio%2Fwav%2Caudio%2Fflac&path=%2FMedia1.mp4 could not be decoded. index
    All candidate resources failed to load. Media load paused. index
    Media resource http://10.10.11.3:8080/assessment/taoItems/ItemContent/downl…Caudio%2Faac%2Caudio%2Fwav%2Caudio%2Fflac&path=%2FMedia1.mp4 could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006)
    Details: static MP4Metadata::ResultAndByteBuffer __cdecl mozilla::MP4Metadata::Metadata(mozilla::ByteStream *): Cannot parse metadata index

    Access Logs attached.

  • Could you attach the video in question, please

  • Please find the videos attached. Moreover I have tried with few other videos of MP4 format, and got same result.

  • I am unable to duplicate the issue with your videos. What webserver are you using?

  • edited November 11

    I am using WAMP 3.1.9
    Apache 2.4.39 , PHP 5.6.40, MySQL 5.7.26

    If I add Youtube video URLs, its working but not with uploaded videos and other direct video URLs. Moreover when I download the uploaded videos and try to play using other media players, it's corrupted and not playing.

  • What version of TAO are you using? The latest version of TAO is on PHP 7.2.

  • Am using 3.2.0-RC2

  • You will need to upgrade to TAO 3.3-RC02

  • Can you please guide me with the upgradation process, as 3.2 is already in production with lots of content.

  • @Amy Thank you for your help.
    Is there any tutorial explaining how to do upgradation for windows system ?

  • You should be able to use the same commands on a windows 10 system with windows for git installed. If you are using the windows installer that is only meant for trials/Proof of Concept.

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×