Forum

Issue while upgrading from 3.2 to 3.3

edited November 18 in Developers

Hi Team,

While upgrading from version 3.2.0-RC2 to 3.3 following instructions mention here, I am getting below error. Please suggest, how can I fix this.

Configuration:
Windows 10, WAMP 3.1.9, Apache 2.4.39 , PHP 7.2.18, MySQL 5.7.26

Error:
After
1. cp /TAO_3.3.0_sprint-96-97_final/composer.{json,lock} .
2. composer install
when I am executing below command:
php tao/scripts/taoUpdate.php

    Fatal error: Uncaught common_exception_Error 'Missing extensions taoQtiTestPreviewer for: taoCe' in C:\wamp64\www\assessment\generis\helpers\class.ExtensionHelper.php(74)

                                        #0 C:\wamp64\www\assessment\tao\models\classes\class.LanguageService.php(278): helpers_ExtensionHelper::sortByDependencies(Array)
    #1 C:\wamp64\www\assessment\tao\models\classes\class.LanguageService.php(249): tao_models_classes_LanguageService->buildServerBundle('da-DK')
    #2 C:\wamp64\www\assessment\tao\models\classes\class.LanguageService.php(174): tao_models_classes_LanguageService->generateServerBundles()
    #3 C:\wamp64\www\assessment\tao\models\classes\extension\UpdateExtensions.php(52): tao_models_classes_LanguageService->generateAll()
    #4 C:\wamp64\www\assessment\tao\scripts\taoUpdate.php(28): oat\tao\model\extension\UpdateExtensions->__invoke(Array)
    #5 {main}
      thrown in C:\wamp64\www\assessment\generis\helpers\class.ExtensionHelper.php on line 74

Thanks

Comments

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×