Forum

Can't get TAO working with Moodle through LTI

Hi guys,

I'm trying to get TAO to work with Moodle to deliver a test. I've configured everything according to the manual, but I keep getting a blank screen in Moodle.

TAO and Moodle are both configured on the same webserver. The logfile on the website keeps returning this error:

[Tue Jul 18 21:05:18.747914 2017] [lsapi:error] [pid 273436:tid 140424486647552] [client 213.93.210.118:50761] [host www.haste.nl] Backend fatal error: PHP Fatal error: Cannot redeclare class OAuthException in /home/deb29122/domains/haste.nl/public_html/tao/tao/lib/oauth/OAuth.php on line 0\n

Anybody knows what's going wrong?

Thanks in advance.
Ruud

Comments

  • I am very much interested in this topic, hope you have solution soon.

  • Hi,

    What version of Tao are you using?

  • Hi Joel, I'm using version 3.1.0-RC7
    I've just installed Moodle on a different server and tried to make a connection. Still getting the error:
    Fatal error: Cannot redeclare class OAuthException in /home/deb29122/domains/haste.nl/public_html/tao/tao/lib/oauth/OAuth.php on line 0

  • Hi Ruud,

    Long time no speak ;-)
    What version of PHP are you using?

    Thanks,

    Mark.

  • Hi Mark,

    :) Nice company you're working for nowadays!

    It was version 5.6... I just tried it version 7.0 and it seems to work now! :D In my mind I thought I'd tried 7.0 and even 7.1.. apparently I didn't.

    Thnx for the support!

  • Update: It doesn't matter if I use version 5.6 or 7.0. The error is shown when the extension oauth is activated.

  • edited July 2017
    Hi everyone,
    I've got the same Problem like ruud. Although i'm using TAO 3.1.0-RC7, my testtakers don't see anything of the test-items when they start their Tests.

    I Hope you hab help me.

    Thanks,

    Marcel
Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×