Forum

Access denied Please renew your authentication

edited April 28 in Peer Support

Hello Team,

Can some one put some light on error "Access denied Please renew your authentication" when im trying to access TAO in login page

Error in Apache Error Logs

PHP Fatal error: Uncaught TypeError: core_kernel_classes_Resource::__serialize() must return an array in /var/www/html/tao/tao/models/classes/mvc/Bootstrap.php:183\nStack trace:\n#0 /var/www/html/tao/tao/models/classes/mvc/Bootstrap.php(183): session_write_close()\n#1 /var/www/html/tao/tao/models/classes/mvc/Bootstrap.php(234): oat\tao\model\mvc\Bootstrap->dispatchHttp()\n#2 /var/www/html/tao/index.php(31): oat\tao\model\mvc\Bootstrap->dispatch()\n#3 {main}\n thrown in /var/www/html/tao/tao/models/classes/mvc/Bootstrap.php on line 183

PHP Notice: session_start(): Unexpected end of serialized data in /var/www/html/tao/tao/models/classes/mvc/Bootstrap.php on line 279, referer: http://localhost/tao/tao/Main/login
[Tue Apr 28 12:35:13.772572 2020] [php7:warn] PHP Warning: session_start(): Failed to decode session object. Session has been destroyed in /var/www/html/tao/tao/models/classes/mvc/Bootstrap.php on line 279, referer: http://localhost/tao/tao/Main/login

Im using Ubuntu 20.04 ,Latest TAO 3.3 ,Apache2, PHP 7.4 , Mysql 8.0.19-0

Comments

  • edited April 28

    Can some one respond

  • Should better work with PHP 7.2. :D

  • I have the same error. When I switch to PHP7.2 I get instead a HTTP500 error. How do I fix this? Where do I see what's the problem (which logs, how to activate them)? Is it really necessary to run it on PHP7.2? And if yes, do I need to re-install the whole TAO testing after switching the version, or why does it give me a 500 error even with the test-user (which is not the case when running on PHP7.4)?

  • Addendum: I could activate the tao logger. When I switch to PHP7.2 it says "tao INFO could not find driver {"file":/var/www/html/tao/tao/models/classes/mvc/error/ResponsesAbstract.php", "line":134}" and a hashed uid. This doesn't help me much. Neither in PHP7.2 nor in PHP7.4 I can make it work, although in PHP7.4 at least the guest access works.

  • edited June 8

    Addendum: when using PHP7.2 instead of PHP7.4 the installation apparently has problems with the driver, the SQL authentification methods etc. And even when I manage to get through all of them, I get the SAME error "Access denied Please renew your authentication". Please upgrade TAO for PHP7.4, Ubuntu 20.04 and the SQL8.

  • Tao is unusable on PHP 7.3 7.4 without this fix. This should be high`est priority in my view.

  • AFAIK as of today only PHP 7.2 is fully compatible with TAO.

  • PHP 7.2 is not under Active Support from November 2019.

  • I'm also having this error, have been troubleshooting it for 3+ days at this point.

    Using:
    * PHP 7.2
    * Ubuntu 18.04
    * Apache 2.4

    @Cyril_Hazotte: I've seen you mention using the Logger, but I'm struggling to find where to enable it and where to view it's output. This is the only documentation I can find related to logging, but this seems far too complicated for simple logging, can you point me in the right direction to provide the logs to you?

  • So, as it turns out, I get this error when installing via the taoInstall.php script. When using the web installer, I still get an error, but it functions after a reboot. I'm now trying the install using a config file, although functionality which generates a template doesn't seem to exist that I've found. Maybe would be a good feature request?

  • edited July 2

    Using the web installer with the same information yields:
    write-error
    Although, this doesn't seem to be the end of the road, as the visiting http://domain/tao yields a working server.

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×