Forum

How will we get the tests and results in platforms other than moodle?

edited July 2017 in Developers

May i know how do we get the result or do we have an API end point to see the response from Tao Server? Could you pls provide me a sample url.I am working on the local-host and we have a requirement like we need to integrate not only in moodle but also the Tao in any platform as a plugin or platform independent.

I have tried TAO in my local instance and worked .
I need the things in both English and Arabic . Do you have Arabic support or how will you manage Arabic?

I tested in Moodle now. Later we are developing a platform based on Java and we wish to use TAO there . How can i pull the test or assessments in java.Which formate will you support . Eg. XML,API etc. Please give me a detailed view on this.

Because we need the tests results and we are going to do some adaptive learning method based on the each test results.
Please guide me if you have that kind of flexibility .


******

Also i found the following error message when i checked the result in Tao.
~~500:
Warning: strpos() expects parameter 1 to be string, array given in C:\xampp\htdocs\tao\tao\helpers \class.Uri.php on line 255
Notice: Array to string conversion in C:\xampp\htdocs\tao\tao\helpers \class.Uri.php on line 269
{"success":false,"type":"Exception","mes sage":"Property (http:\/\/www.tao.lu\/Ontologies\/TAODel ivery.rdf#DeliveryExecutionDelivery) of resource (Array) should not be empty","data":{"ExceptionType":"core_ker nel_classes_EmptyProperty"}}~~

Comments

  • Same here, i got the same error when trying to look at the answers in TAO. Only for the tests that has been perfromed in moodle.

  • oh I cant delete them either.

  • There was an issue with the results for newer versions of Moodle, as Moodle uses a json encoded array and we failed to encode it properly. This has been fixed on the latest development version

  • @Joel thanks for your reply. im running 3.1.0-RC7 and used the windows installer package. whats the procedure to update?
    thanks

  • tried using php to update but it seems to fail?

  • Sorry for this very late answer, but this step needs to be run AFTER the code has been updated. The latest development version needs to be downloaded from github via composer. Please see https://github.com/oat-sa/package-tao for a quick guide

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×