blank page after starting test

Hi everyone,
i created a test on TAO 3.1.0-RC7, but when my test takers start the test they get a blank page, although the starting page with start and end date of the test is visable.

I hope you can help me.




  • I am getting the same issue. This is a fresh install of 3.1. I was able to duplicate this issue by simply publishing the example test.

  • Hi,

    Do you have any error shown in the server error log or in TAO logs?
    To activate TAO logs, edit config/generis/log.conf.php accordingly.


  • I also have this issue. Fresh install 'TAO_3.1.0-RC7', debian 8.9, PHP7.0, Apache/2.4.10, mysql 5.5.57. Did install, able to create basic test questions, created test user and group. Created deliverable. Logged in as test user and selected test, I get TAO border (with user name and logout option at the top, and a blank page where the test should be.

    Also, the preview option for the test items gives a '!500' when I click submit, but the black bar at the bottom seems to indicate it worked. Checked everything I can find and it looks to me like the question is setup correctly. It's a very basic multiple choice test.

  • Unable to enable logging. TAO will no longer load if I uncomment the logging options.
    Above testing was done with Firefox (55.0.1 64bit)
    IE gives a server 500 error.

  • Resolved for me. Solution was to roll back to PHP5

  • Rather than getting a blank page, I'm getting errors, but it could be because I installed a development configuration. This is the error I'm getting:

    Fatal error: Cannot use qtism\common\datatypes\Float as Float because 'Float' is a special class name in /var/www/html/taoQtiTest/helpers/class.TestSession.php on line 31

    I'm still early in my investigation, but it looks like hasn't been built into the current release and is causing datatype mismatch errors. I'll report back after I've learned more.

  • I had the same problem with GoDaddy hosting. Rolled back to PHP v5 and the QTI sample test worked fine.

  • Hi donsmith,

    TAO 3.1 is only compatible with PHP 5.6, not PHP 7.x.



  • Thank you @Cyril_Hazotte. I came across that solution in other threads and it worked for me too.

Sign In or Register to comment.

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy