Forum

jeppebundsgaard

About

Username
jeppebundsgaard
Joined
Visits
112
Last Active
Roles
Member

Comments

  • Thanks, Hoshisato! I guess you're right. I would suggest that someone (that could be me in collaboration with others...) took on the task of implementing a method to support multi-language tests. I cannot be the only one needing that.
  • I had similar problems with an update of an extension and got similar error messages. Unfortunately I didn't manage to solve the problem - I couldn't update from tao 27.1.4 to a newer version. When asking in this forum, I just got the answer that …
  • Sorry stephan_cgn - I don't get emails from this forum, so I didn't see your request. My solution was to first create new tables in the new database tao_results - here as export output from phpmyadmin: CREATE TABLE `delivery` ( `id` int NOT NU…
  • I solved my problem by writing a script that downloads the student responses directly from the database - including the correct duration times. So I don't need this update anymore, and I will just wait for the update and instructions. Thanks, Je…
  • The problem is that I need to get access to the bug fix of the duration problem (all durations above 1 minute are just reported as the seconds parts). And that bug fix depends on newer versions of generis and tao... So if you could help me to find o…
  • This howto: https://hub.taotesting.com/articles/server-migration/server-migration-tao-30 tells you to copy data and config folders and the database when migrating - which would be kind of the same thing as installing a backup. But I would suggest t…
  • Amy, did you have an idea of what goes wrong here? It would be a big help to get the correct duration data out and into our analysis of the student responses. Thanks in advance for you help.
  • I am using PHP 7.2.28-3+ubuntu18.04.1+deb.sury.org+1 and TAO 3.3.0-RC02. I just installed npm and retried, but I get the same error.
  • I tried to install the development version of the extension, but I get the error below Calling: composer require oat-sa/extension-tao-outcomeui sudo php tao/scripts/installExtension oat-sa/extension-tao-outcomeui PHP Fatal error: Uncaught An…
  • Hi Amy, I have the same problem. Is the problem fixed? If so: Is a new version released with the fix - or would I be able to get the update from github? (which files?) Thanks! Jeppe
  • It works now. Actually I don't know what I did to make it work. Sorry for that.
  • And to follow up: When I want to import users, I can have a Groups column. I tried here as well with a Group Resource Identifier, but the user isn't assigned to the group.
  • I have been thinking. I started out with php7.3, and later downgraded to 7.2. Maybe the problem was something related to php7.3. So if someone is having the same type of problem, maybe look for problems related to that... I don't know. I would like…
  • Okay... Solved. I took a bite of the sour apple, as we say in Danish, and reinstalled and re-imported my items. Now I see the images... I guess we will have to live without knowing the reason for this strange behavior...
  • I just installed tao in another subdomain on the same server. It worked! I looked into the apache-directives - everything was the same. So I guess something is wrong with the install, not with the server. So now I need a good advice on how to repl…
  • I looked there. The only path I could see as possibly related was FILES_PATH which was just data/. I tried to install tao3.3 locally and there the path was from the root dir, so I tried to change that in my production tao instance (to: /var/www/tao3…
  • Here is an example. In taoQtiItem in the model/QtiItemCompiler.php-file, we have e.g.: Lines 201-205: common_report_Report::TYPE_SUCCESS, __('Successfully compiled "%s"', $language) ); } catch (\tao_models_classes_FileNotFoun…
  • Yes. I tried to replace the image with a new one. Now I also tried to create a new item, insert an image from the media gallery, and deliver. Then I created another item, inserted an image that I uploaded, created a new test and delivered. It is al…
  • I found the howto: https://hub.taotesting.com/articles/installation-and-upgrading/update-translations-in-tao-with-a-translation-package-from-pootle Thanks!
  • Hi Amy, Great to see that TAO 3.3 is now released. I am still struggling with this error. By looking a little more into the error messages and the script referred to, BaseWebsource.php, it seems that the two error messages are indeed connected, and…
  • I managed to find the file in the file system: data/tao/public/2/0/b/a3cace62d8d8f0718b0d001500eb4/en-US/aee651835d4142e0151c1.jpeg - so I guess the problem is in a path somewhere?
  • I managed to set up the debug logger. I get this: [2019-07-31 16:23:29] tao.INFO: File 2/0/b/a3cace62d8d8f0718b0d001500eb4/en-US/aee651835d4142e0151c1.jpeg not found {"0":"tao_models_classes_FileNotFoundException","file":"/var/www/tao33/tao/mode…
  • The guy working on it stopped (our funding ran out). But I'll try to get funding for this. First hurdle would be to succeed in making a view of the student's response in the item context. I you could sketch out how that could be done, I would take t…
  • Downgrading didn't help (I thought I saw somewhere that php7.3 was the one for this release, but I guess I remembered wrong). .htaccess: Options +FollowSymLinks RewriteEngine On SetEnv HTTP_MOD_REWRITE on #don't match resources and tests Rewrit…
  • I tried to replace an image and make a new delivery to see if it was connected to the import, but the same problem appears. So it seems like the problem is viewing of images in general. Could this be connected to that this instance has a default en…
  • I looked for the image to find out if it was copied as part of the export/import, and I found it in a subfolder to this new 3.3-installation ("./data/tao/public/6/f/f/bb7abd4b13c8bb8b68c67f60c7b1e/en-US"), so it seems that the images are copied as p…
  • I think this is the biggest drawback of using TAO. I was also surprised to find out that the human scoring system was abandoned. We did actually try to develop the basis for a human scoring system to be integrated in TAO, and we had a sketch of the …
  • I am using PHP 7.3. I have debug mode set to true, but I don't get anything in the apache-error-log. In the browser console, I get: "Failed to load resource: the server responded with a status of 404 (Not Found)". Should I look somewhere else for…
  • Hi Amy, Thanks for the swift response, and great to hear that you are the new community liasson! Yes, I did use that article, and the csv-file was based on the template. But I removed the language column - because I didn't find a reference to Dan…

We use cookies on our website to support technical features that enhance your user experience. Cookie Policy Privacy Policy

×